… GPSMAP 278

im Prinzip das geilste Navi das ich je hatte, und es waren Einige.

Garmin Streetpilot III
TOMTOM One
BMW Navigator II (Garmin 2610) mit Cradle
Garmin GPSMap 276c +256
Garmin GPSMap II plus
Garmin GPSMap 278 +128
Garmin zumo 400 DACH-CZ +2GB +NT2008

Mit dem 278 laesst sich im Prinzip alles machen, was das Herz begehrt, vom Tracking ueber Routenplanung und die mitgelieferte MapSource ist quasi Narrensicher. In Verbindung mit TTQV staune ich jeden Tag neu ueber die irrsinigen Funktionen … Multitrackreplay, eine grosse Show.

Aber dann wars soweit, die Fa. Garmin kuendigt es an, das Update auf NT 2008, die Bestellung geht sofort raus und dann war warten angesagt. Und danach aergern.

naja, angefangen hats ja gestern abend, die update dvd von garmin kam nach 8 wochen dann doch noch per  Post aus uk an und ich wollte natuerlich gleich ein update machen.

denkste puppe. bricht ab und was bleibt ist die basemap. also gegoogelt und siehe da,
das ist quasi \’normal\‘, das es nciht geht. es haben sich bald 1 dutzend leute nur gestern im naviboard gemeldet, denen es aehnlich ergangen ist. also loesung suchen, denn ein neuerliches update bietet die update dvd ja nicht an.

will man unbedingt sein navi gleich nutzen so bleibt der weg ueber den garantieverlust wenn man garmin glauben schenken darf. 😉 schwachfug

howto:

  1. Erstmal einen Kartensatz aller CN NT 2008 Karten erstellen in Mapsource und diesen umbennen (unterhalb der Kartenliste).
  2. Diesen an einen Wechseldatentraeger per Mapsource senden (z.B. SD Card).
  3. Einen Ordner c:\GPS278 auf der Festplatte erstellen
  4. kopiere von der SD Karte die gmapsupp.img nach c:\GPS278
  5. Benenne das File in von gmapsupp.img nach gmapprom.img um
  6. SD Karte entfernen und Gerät per USB anschließen
  7. Eingabeaufforderung öffnen (cmd Shell)
  8. Folgenden Befehl eingeben (ggf. Pfade anpassen)

C:\Garmin\WebUpdater.exe /upload_file rgn=49 path=C:\GPS278\gmapprom.img -autorun usb /unlock_check fid=284 pid=1 /i

webupdater= das tool, das garmin liefert fuer updates aller art.
upload_file= klar, hochladen soll er
rgn=49 = Speicherbereich des Geraetes (1. interner Speicher)
path= der pfad des prom(intern) files
autorun usb= versuch gar nicht erst auf seriell
unlock_check= lade nur wenn freischaltcode ok

fid=284= family ID, jeder kartensatz gehoert zu einer familie
(CN 2009 hat ID 378, CN 2010.30 hat ID 2200, die 2011.10 hat ID 2204)

pid=1= Product ID Nummer
/i= installationsmodus

der Aufruf fuer die aktuellste (Stand Februar 2010) Version, nach dem erstellen eines IMG fuer das Geraet lautet demnach:

C:\Garmin\WebUpdater.exe /upload_file rgn=49 path=C:\GPS278\gmapprom.img -autorun usb /unlock_check fid=2200 pid=1 /i

wer mag, kann noch mit checksum pruefen lassen ob alle daten ordentlich ankamen … was aber nochmals dauert.

was besonders aergerlich ist wenn das Update von CD nicht klappt:

  1. alle usb ports waren NICHT auf stromsparen
  2. genau! nach garmin vorgabe vorgegangen
  3. keine moeglichkeit neu zu installieren (habe 2 weitere rechner hier)
  4. kein support bis dato (oder hat jemand antwort?)
  5. updates fuer geraete in dieser liga muessten 100% laufen
  6. allgemeine kundenverarsche [1]
    [1]*routing auf BAB sei ein feature, schnellstrassenproblem NICHT existent
    *displaybeschichtung loest sich, muss wohl mechanisch was gemacht worden sein, unsere displays sind immer top
    *update dvd ist in 3 – 5 werktagen da
    *es ist KEINE Preissenkung zu erwarten (vor 3 wochen)
    achja … 😉 Garmin meint allen ernstes, das man mitder aktion sein navi zu retten seine garantie verliere.von daher, bitte NICHT nachmachen. schickt doch lieber euere navis ein, ist ja nur sonne draussen, wer will da schon Mopped fahren.

UPDATE 23.08.2008
Nachdem ich 2 x bei Garmin war um das Geraet auf den offiziellen und heiligen Garminstand zu bringen, habe ich wieder alles neu machen muessen. Das erste Mal spielte man mir ein Image auf, das nicht zu meinem CN NT 2008 Karten passen wollte und beim zweiten Mal muss auch irgendwas schief gelaufen sein, denn ich konnte ploetzlich wieder keine Routen von MapSource nach 278 uebertragen, die zumo 400 Routen machten aber kein Problem. Also wieder das oben beschriebene Prozedere durchgemacht und siehe da, alle erstellten Routen lassen sich aktivieren. Was solls, ich werde also in Zukunft auch mehr meinem Gefuehl als den Weissagungen von Garmin trauen.

Das zumo400, das ich vor Kurzem kaufte und doch zu selten verwende, kommt nun kam mit allem Zubehoer und Update auf City Navigator NT Europe 2008 ALL Regions auf 2 GB SD Karte in die Elektrobucht. Waer schade wenn es nur rumliegt und wert verliert. [Update]: uuuund verkauft an den jungen Mann aus NRW.

Update 03.12.2008
Immer mal wieder kommen Fragen zum uebertragen der Karten in den internen Speicher, dazu ein paar kleine Hinweise.

  • man kann natuerlich seine Karten frei zusammenstellen in der Mapsource, so kann man Topokarten und auch City Navigator anderer Regionen (AUS z.B.) verwenden. Auch Topo Austria/CH oder lettische Hoehenlinien, in meinem Fall Topo Schottland. Dazu einfach im DropDown Menu von MapSource die Karten wechseln und weiter auswaehlen. Den Kartensatz umbenennen am Ende nicht vergessen. Ich nenne eigene Sets immer so, das ich weiss welcher es ist. (z.B. CNNT2008-TopoD-TopoA)
  • die Topographischen Karten von Topo D liegen hinter den CN Karten, daher die Topo Karten per IMG Transparency 2a auf transparent umstellen (readme erklaert da alles) und dann zufuegen. Die Route erkennt man nicht mehr so gut, da dass Magenta nicht immer durscheint aber man sieht Topo ueber CN und kann Autorouting machen.
  • Die Karten sind nun ein Set, man kann sie nicht deaktivieren. Doch, dazu benoetigt man nur eine Garmin Speicherkarte (proprietaeres Format und teuer oder eben ne kleine 128MB von ebay) und spielt auf diese von jedem Kartensatz eine einzige Kachel drauf, jedoch keine der eigentlich internen City navigator 2008 / 2009, denn die sollen ja immer an sein. Um die nicht gewuenschten Sets nun abzuwaehlen, einfach die Datenkarte ziehen, die internen Topos sollten nun nciht mehr angezeigt werden.
  • Wieviel Platz hat man zur Verfuegung? Man spricht von knapp 2 GB, jedoch scheinen es doch eher nur 1.7 GB zu sein die man uebertragen kann. Ob es einem tatsaechlich nur 1.7 GB grossen internen Speicher oder einem reservierten bereich fuer Wayponts, Tracks, Tiden, Berechnungen geschuldet ist, das weiss ich leider nicht.

Update 2010-01-08
Ein seltener aber leider ab und an vorkommender Fehler ist das fehlerhafte Firmware Upgrade. Wenn das Firmwareupgrade abbricht, meldet das Navi:  „System Software Missing“. Nun kann man noch 3 Dinge versuchen um dem Herr zu werden. Klappt auch Schritt 3 nicht, so kommt man um ein Einsenden zu Garmin nicht herum.

  1. man versucht die Testpage zu erreichen -> POWER + ENTER beim einschalten druecken
  2. Masterreset ausfuehren -> POWER + OUT + QUIT + NAV fuer mindestens 10 Sekunden halten
  3. Restore Mode -> POWER +PAGE +ENTER +DOWN beim einschalten druecken und NUR Power loslassen, so dass PAGE + ENTER +DOWN gedrueckt bleiben und NUN (mit gedrueckten Tasten) erneut die Firmware aufspielen.

Viel Spass mit dem 278.

  1. nils
    4. März 2009, 00:22 | #1

    ja nee, is klar…

    mann sucht nach nem update howto fuers 278 und wo landet man??

    ma kucken, ob das taucht 😉

    gruss aus augsburg!

  2. jpb
    5. Juli 2010, 22:51 | #2

    tolle Anleitung auf die ich jetzt häufiger hinweisen werde – dann bleibt mir das regelmäßige Neuerklären erspart – Danke!
    Jörg

  3. Frank
    9. April 2011, 15:17 | #3

    Hallo,

    ich wollte das gerade probieren, aber ich habe
    keine SD- Karte
    und bin wohl zu blöd, bei Mapsource 6.16.3 die Karten zu speichern, finde keinen Punkt dafür.

    Geht das nicht auf ne USB-Platte auch?

  4. 9. April 2011, 20:15 | #4

    einfach die Karten markieren, dann unten links richtig benennen (sonst heisst die Karte, wie die ersten paar Kacheln) und dann auf „send to device“ (sende an geraet). Dort ist ein PullDown Menu. Dieses enthaelt das Navi (sofern erkannt) und die SD Karte, da manche Geraete eben auf SD/SD Micro aufbauen. Auf USB Platte soweit ich weiss nicht. Ich habe damals einfach einen 2.99 EUR USB Cardreader mit einer SD Karte angesteckt.

  5. Frank
    9. April 2011, 22:27 | #5

    Hat sich erledigt, nachdem ich ne SD-Karte von meiner Frau bekommen hatte.

    Update geht übrigens auch mit

    C:\Garmin\WebUpdater.exe /upload_file rgn=49 path=C:\GPS278\gmapprom.img -autorun usb /i

    Gruß
    Frank

  6. 16. Mai 2012, 10:31 | #6

    hallo,

    vielen dank für die anleitung zum aufspielen der karte. es hat prima geklappt.

    mein gpsmap 278 hatte sich abgeschaltet und beim selbstständigen neustart mit der fehlermeldung aufgewartet: cannot unlock maps.
    sämtliche routen, waypoints und tracks waren verschwunden und auch mein persönliches setup. die karte stand irgendwo in den usa.

    ich habe also mein originales city navigator nt 2008 nach anleitung wieder aufspielen können.
    allerdings habe ich nun (ausser den hauptmenü-seiten) nur noch die karten-seite und eine vorher nicht vorhandene trip-computer seite. die anderen seiten sind verschwunden.

    meine frage: kann ich die vielleicht irgendwo im setup wieder anschalten???

    vielen dank…
    -=airhead=-

  7. 16. Mai 2012, 11:24 | #7

    es gibt im setup menu einen punkt (ich glaube display … jedenfalls weit unten), wo man kompassseite und so aktivieren kann. der tripcomputer ist eine der moeglichen ansichten der unterseite. wenn man auf der seite ist, kann man durch langes druecken einer taste (evtl. menu?) die ansichten definieren. ich haette meinen 278 nicht verkaufen sollen .. leider habe ich auch die einstellungen schon wieder halb vergessen, frueher konnte ich das blind. manche schalten auch aus versehen von strasse auf marine um, dann sind die detailkarten nicht sichtbar und die unterseiten sehen auch anders aus.

  8. 16. Mai 2012, 13:18 | #8

    super…danke, die schalter waren „autobahnseite ein“ und „kompassseite ein“. was jetzt noch fehlt ist die seite mit den aufgelisteten abbiegeinstruktionen für routen.

  9. 16. Mai 2012, 13:22 | #9

    hmm, ich bin mir nicht sicher ob das eine einstellung war oder ob man nur NAV druecken musste. eine einstellung ob die abbiegeinformationen kommen, gab es glaube ich aber. falls hier jemand ein 276 oder 278 ueber hat, ich glaub ich will wieder eins 😉

  10. 16. Mai 2012, 13:35 | #10

    hallo phil,

    mit der taste [page] konnte/kann man die einzelnen seiten durchschalten: kartenseite, kompassseite, autobahnseite, trip-computerseite und die jetzt noch fehlende seite mit den aufgelisteten abbiegeinstruktionen.

    ich vermute mal, da gibts auch irgendwo den schalter, um die anschalten zu können.

    p.s. alles klar…man muss zunächst natürlich eine route aktivieren…
    jetzt ist wieder alles bestens…

    vielen dank…:)

    -=airhead=-

  11. 16. Mai 2012, 13:39 | #11

    hallo phil,

    ich vermute mal, da gibts auch irgendwo den schalter, um die anschalten zu können.

    p.s. alles klar…man muss zunächst natürlich eine route aktivieren…
    jetzt ist wieder alles bestens…

    vielen dank…:)

    -=airhead=-

  12. 1. Juni 2012, 21:51 | #12

    eben habe ich versucht CN NT 2013.10 nach der von dir beschriebenen methode auf mein gpsmap 278 zu spielen. die befehlszeile lautete: C:\Garmin\webupdater\WebUpdater.exe /upload_file rgn=49 path=C:\GPS278\gmapprom.img -autorun usb /unlock_check fid=2628 pid=1 /i
    die karte hatte ich auf 1700mb abgespeckt.

    es erschien die fehlermeldung:
    webupdater
    ungültige befehlssytax…

    was mache ich falsch?

    -=airhead=-

  13. 2. Juni 2012, 18:00 | #13

    lass doch mal testweise den check weg… und achte darauf, dass das image auch
    wirklich in C:\GPS278\ liegt. Vielleicht hat aber auch der Webupdater mittlerweile neue Syntax erhalten, ich habe leider kein 278er mehr, daher benutze ich auch keinen Webupdater mehr.

    C:\Garmin\Webupdater\WebUpdater.exe /upload_file rgn=49 path=C:\GPS278\gmapprom.img -autorun usb /i

  14. 3. Juni 2012, 11:18 | #14

    @phil

    der webupdater ist derselbe, den ich zum aufspielen von CNT 2008 benutzt habe.

    werde also mal den den check weglassen.
    dann noch zwei fragen:
    wird die alte alte version beim aufspielen auf den gpsmap jeweils überschrieben?
    wie kann ich die auf den pc aufgespielte 2013er version notfalls wieder löschen?

    -=airhead=-

  15. 3. Juni 2012, 13:45 | #15

    ok, dann sollte die syntax aber passen. die alten karten werden automagisch errsetzt. wenn das neue image aufgespielt wird, ist das alte image weg. vom PC (ich nehme an PC und nicht Mac) kann man alle Kartenversionen einfach ueber die Systemsteuerung (Software) wieder deinstallieren.

  16. 3. Juni 2012, 19:52 | #16

    @phil
    hallo phil,

    vielen dank, mit C:\Garmin\Webupdater\WebUpdater.exe /upload_file rgn=49 path=C:\GPS278\gmapprom.img -autorun usb /i , also ohne checker, hat es einwandfrei funktioniert.

    -=airhead=-

  17. 2. Februar 2013, 18:08 | #17

    Verdammt, es klappt nicht.
    wenn ich in den Prompter cmd shell eingebe erscheint: c:\users\Torsten> ich vermute daran hängts bereits. c:\users\Torsten>c:\Garmin\Webupdater\WebUpdater.exe /upload_file rgn=49 path=C:\GPS278\gmapprom.img -autorun usb /i bringt folgendes Ergebnis: Das System kann den angegebenen Pfad nicht finden.

  18. 4. Februar 2013, 12:46 | #18

    gibt es denn den pfad?
    also einmal den zum webupdater.exe und zum anderen, den pfad zum gmpapprom.img in c:\GPS278?

  19. Magpie42
    13. Mai 2013, 17:29 | #19

    @Waldschrat
    Hi Waldschrat,

    Dein „c:\users\Torsten>“ ist ok, das gehört so. Und zeigt nur an, in welchem Verzeichnis (vulgo „Ordner“) Du Dich gerade befindest.

    Dein aktuelles Problem ist, dass Dein „cmd“ die WebUpdater.exe nicht findet (die Du hoffentlich vorab installiert hast?).
    Da es unterhalb von „C:\users“ startet, vermute ich mal, dass Du Windows 7 verwendest. Bei der 64-Bit-Version wird WebUpdater typischerweise nach „C:\Program Files (x86)\Garmin\WebUpdater“ installiert. Zusätzlich ist wichtig, dass Du die Version 2.5.6.0 vom WebUpdater verwendest (ist die derzeit aktuellste). Damit versuch’s dann mal so:

    C:\Program Files (x86)\Garmin\WebUpdater\webupdater.exe /i /autorun usb /upload_file rgn=49 path=C:\Garmin\gmapprom.img

    Sollte das ebenfalls mit „Das System kann den angegebenen Pfad nicht finden“ fehlschlagen, suche erst mal nach der webupdater.exe und passe den o. gen. Pfad entsprechend an.
    Falls Du einen Syntax- bzw. Verwendungs-Fehler bekommst, hast Du die falsche Version – lade Dir dann als erstes den WebUpdater v2.5.6.0 bei Garmin herunter.

    HTH!

    Cheers, Magpie

  20. Volker
    27. Juli 2014, 09:43 | #20

    ich habe lange versucht (Windows 7) die cmd mit dem Pfad C:\Program Files (x86)\ als Befehl verarbeitet zu bekommen.
    Das hat nicht funktioniert, ständig Fehlermeldungen “ Der Befehl C:\Program“ ist entweder falsch geschrieben oder konnte nicht gefunden werden. Auch Lösungsansätze mit % und entfernen der Leerzeichen haben nicht geholfen.
    Der WebUpdater kann nicht in ein bestimmtes Verzeichnis installiert werden, der Pfad wird nicht abgefragt.
    Lösung war dan den Pfad der WebUpdater-Instalation von C:\ProgramFiles(x86)\ in ein anderes Verzeichnis zu kopieren, in dem Fall direkt auf C.

    So nun ist alles gut aber ohne die Hilfe hier hätt ich das nicht geschafft!

  21. Jörg
    21. August 2014, 19:00 | #21

    Bei Pfaden, die Leerzeichen enthalten, immer führende und abschließende Anführungszeichen verwenden, damit dies als zusammenhängender Parameter verstanden wird. Beispiel:
    „C:\Program Files (x86)\Garmin\WebUpdater\WebUpdater“ /upload_file rgn=49 path=C:\Garmin\278er_Upload_2015.20\gmapprom.img -autorun usb /i

    Das sollte auch für den Pfad zum Image funktionieren.
    Auf 32 Bit Windows >= 7 sähe das so aus, nur ‚ (X86)‘ fehlt:
    „C:\Program Files\Garmin\WebUpdater\WebUpdater“ /upload_file rgn=49 path=C:\Garmin\278er_Upload_2015.20\gmapprom.img -autorun usb /i

  1. Bisher keine Trackbacks
*